debian/rules
branchstable
changeset 5294 29f3680823e9
parent 4913 cac7e750422f
equal deleted inserted replaced
5285:8d955635cf45 5294:29f3680823e9
     6 
     6 
     7 ifeq (,$(filter nodoc, $(DEB_BUILD_OPTIONS)))
     7 ifeq (,$(filter nodoc, $(DEB_BUILD_OPTIONS)))
     8 override_dh_auto_build:
     8 override_dh_auto_build:
     9 	dh_auto_build
     9 	dh_auto_build
    10 	# Workaround for Sphinx in Debian Buster defaulting to Python 3
    10 	# Workaround for Sphinx in Debian Buster defaulting to Python 3
    11 	SPHINXBUILD="python -m sphinx -bhtml" $(MAKE) -C docs
    11 	#SPHINXBUILD="python -m sphinx -bhtml" $(MAKE) -C docs
    12 endif
    12 endif
    13 
    13 
    14 hgsrc_defined:
    14 hgsrc_defined:
    15 	# Use "! -z" instead of "-n", because "-n" without arguments is true
    15 	# Use "! -z" instead of "-n", because "-n" without arguments is true
    16 	test ! -z $(HGSRC) && test -d $(HGSRC) || (echo "$(HGSRC) is not a directory"; false)
    16 	test ! -z $(HGSRC) && test -d $(HGSRC) || (echo "$(HGSRC) is not a directory"; false)