debian/rules
changeset 4634 0b231ea2124b
parent 4632 a1d191feaa84
child 4645 6292fe564b20
equal deleted inserted replaced
4633:61c2518cd6d2 4634:0b231ea2124b
     4 %:
     4 %:
     5 	dh $@ --with python2 --buildsystem=python_distutils
     5 	dh $@ --with python2 --buildsystem=python_distutils
     6 
     6 
     7 override_dh_auto_build:
     7 override_dh_auto_build:
     8 	dh_auto_build
     8 	dh_auto_build
     9 	$(MAKE) -C docs
     9 	# Workaround for Sphinx in Debian Buster defaulting to Python 3
       
    10 	SPHINXBUILD=/usr/share/sphinx/scripts/python2/sphinx-build $(MAKE) -C docs
    10 
    11 
    11 hgsrc_defined:
    12 hgsrc_defined:
    12 	# Use "! -z" instead of "-n", because "-n" without arguments is true
    13 	# Use "! -z" instead of "-n", because "-n" without arguments is true
    13 	test ! -z $(HGSRC) && test -d $(HGSRC) || (echo "$(HGSRC) is not a directory"; false)
    14 	test ! -z $(HGSRC) && test -d $(HGSRC) || (echo "$(HGSRC) is not a directory"; false)
    14 
    15