[server] Make connection pooler configurable and set better default values
Drop the configuration connections-pool-size and add new configurations options:
* connections-pool-min-size. Set to 0 by default so we open connections only
when needed. This avoid opening min-size*processes connections at startup,
which is, it think, a good default.
* connections-pool-max-size. Set to 0 (unlimited) by default, so we move the
bottleneck to postgresql.
* connections-idle-timeout. Set to 10 minutes. I don't have arguments about
this except that this is the default in pgbouncer.
Tests: unittest
Depends:
python3-cubicweb, cubicweb-ctl,
@builddeps@,
python3-pytest,
python3-flake8,
python3-psycopg2, postgresql, postgresql-plpython,
python3-ldap3, slapd, ldap-utils
Restrictions: allow-stderr, isolation-container
Tests: skeleton-packaging
Depends:
python3-cubicweb, cubicweb-ctl,
python3-pyramid, python3-wsgicors,
devscripts, equivs, lintian, autopkgtest
Restrictions: allow-stderr, needs-root