debian/rules
author Denis Laxalde <denis.laxalde@logilab.fr>
Fri, 18 Nov 2016 09:14:25 +0100
branch3.24
changeset 11835 fafdb7f1e888
parent 11832 e8be49ecb522
child 11836 21c72857178f
permissions -rwxr-xr-x
[skeleton] Rephrase long description of Debian package into something meaningful [ci skip]

#!/usr/bin/make -f
# Sample debian/rules that uses debhelper.
# GNU copyright 1997 to 1999 by Joey Hess.

# Uncomment this to turn on verbose mode.
# export DH_VERBOSE=1

export PYBUILD_NAME=cubicweb
export PYBUILD_DISABLE_python2=test

%:
	dh $@ --with python2,sphinxdoc --buildsystem=pybuild

override_dh_auto_build: export http_proxy=127.0.0.1:9
override_dh_auto_build: export https_proxy=127.0.0.1:9
override_dh_auto_build:
	dh_auto_build
ifeq (,$(findstring nodocs, $(DEB_BUILD_OPTIONS)))
	PYTHONPATH=. sphinx-build -N -bhtml doc/ debian/cubicweb-doc/html
endif

override_dh_install:
	dh_install --sourcedir=debian/python-${PYBUILD_NAME}

override_dh_installchangelogs:
	dh_installchangelogs -Xdoc/changes