debian/cubicweb-twisted.postinst
author Pierre-Yves David <pierre-yves.david@logilab.fr>
Tue, 02 Apr 2013 14:46:13 +0200
branchstable
changeset 8837 f7f4238ffe3c
parent 0 b97547f5f1fa
permissions -rw-r--r--
[service] extract session retrieval from "task" closure The session was retrieved there because `set_cnxset` must be called in the same thread as the code using it. We now retrieve the session beforehand and explicitly call `set_cnxset`.

#! /bin/sh -e

if [ -x "/etc/init.d/cubicweb-ctl" ]; then
    invoke-rc.d cubicweb-ctl restart || true
fi
 
 
#DEBHELPER#
 
exit 0