Fix broken flake8 configuration
and flake8 errors which were hidden by this breakage.
flake8 --filename options doesn't work as expected:
* it's expected to be a shell pattern, using stdlib's fnmatch.fnmatch function
internally. This funciton thinks that 'cubicweb/x.py' doesn't match 'cubicweb/x.py'
(there must be a reason but that's not the point), hence no file was actually
checked ;
* as this is a list of pattern, each encountered file is checked against each
pattern, leading to run time explosion.
So maintain list of files to check in a separated file and give this list to
flake8 using unix's xarg command.
usr/lib/python2*/*-packages/cubicweb/devtools/
usr/lib/python2*/*-packages/cubicweb/skeleton/
usr/lib/python2*/*-packages/cubicweb/test
usr/lib/python2*/*-packages/cubicweb/dataimport/test
usr/lib/python2*/*-packages/cubicweb/entities/test
usr/lib/python2*/*-packages/cubicweb/ext/test
usr/lib/python2*/*-packages/cubicweb/server/test
usr/lib/python2*/*-packages/cubicweb/sobjects/test
usr/lib/python2*/*-packages/cubicweb/hooks/test
usr/lib/python2*/*-packages/cubicweb/web/test
usr/lib/python2*/*-packages/cubicweb/etwist/test