[datafeed] Complete the import log even if parser could not be found
It happens that if the parser could not be found, _pull_data() would just
return an empty dict without taking care to close the import log which it just
opened. This leads to misleading information in the user interface where
CWDataImport entities kept accumulating in the "imports" tab of CWSource
primary view without anything else happening.
So:
* log an error message when parser cannot be found
* always close (write logs and set "end_timestamp" attribute) import log when
leaving _pull_data().
Closes #15505460.
#! /bin/sh -e
if [ -x "/etc/init.d/cubicweb-ctl" ]; then
invoke-rc.d cubicweb-ctl restart || true
fi
#DEBHELPER#
exit 0