debian/cubicweb-twisted.postinst
author Sylvain Thénault <sylvain.thenault@logilab.fr>
Thu, 17 Nov 2016 10:53:04 +0100
branch3.24
changeset 11824 d7ecf6dab085
parent 0 b97547f5f1fa
permissions -rw-r--r--
Fix AttributeError for "lang" on repo/client connections This is a regression introduced by b48020a80dc3, which removed call to set_language from the `req._set_user` method. This is fine, but we still want a language on connections, so we've to handle it if necesary in Connection.__enter__ (i.e. once connection is properly open). When using pyramid front-end, which has a users cache, we've to cache its language as well because we must not access its preferred_language method since it's not bound to a proper connection.

#! /bin/sh -e

if [ -x "/etc/init.d/cubicweb-ctl" ]; then
    invoke-rc.d cubicweb-ctl restart || true
fi
 
 
#DEBHELPER#
 
exit 0