debian/control
author Pierre-Yves David <pierre-yves.david@logilab.fr>
Tue, 27 Nov 2012 11:27:49 +0100
branchstable
changeset 8600 d74addac92bb
parent 8476 864a92b10cb8
child 8535 268b6349baf3
permissions -rw-r--r--
[downloadable] fix filename in HTTP header (closes #2522325, #2522324) Before this changeset we use the `filename` header with utf8 encoded filename all the time. However RFC6266 says: The parameters "filename" and "filename*" differ only in that "filename*" uses the encoding defined in [RFC5987], allowing the use of characters not present in the ISO-8859-1 character set ([ISO-8859-1]). Therefore, we alter the code to: 1. Use `filename` and `ascii` encoding whenever possible, 2. use `filename*` with `utf8` encoding otherwise (with a filename fallback for old browser) We also switch the `content-disposition` value to attachement if filename is specified, this will result as a mandatory download according to RFC6266. This mandatory download is the expected behavior. We changes the filename encoding to RFC5987 which is simpler, supported by all and modern browser (including IE from version 6) and does not suffer from the continuation issue. (see ticket #2522324 for details)

Source: cubicweb
Section: web
Priority: optional
Maintainer: Logilab S.A. <contact@logilab.fr>
Uploaders: Sylvain Thenault <sylvain.thenault@logilab.fr>,
           Julien Jehannet <julien.jehannet@logilab.fr>,
           Adrien Di Mascio <Adrien.DiMascio@logilab.fr>,
           Aurélien Campéas <aurelien.campeas@logilab.fr>,
           Nicolas Chauvat <nicolas.chauvat@logilab.fr>
Build-Depends:
 debhelper (>= 7),
 python (>= 2.5),
 python-central (>= 0.5),
 python-sphinx,
 python-logilab-common,
 python-unittest2,
 python-logilab-mtconverter,
 python-rql,
 python-yams,
 python-lxml,
Standards-Version: 3.9.1
Homepage: http://www.cubicweb.org
XS-Python-Version: >= 2.5

Package: cubicweb
Architecture: all
XB-Python-Version: ${python:Versions}
Depends: ${misc:Depends}, ${python:Depends}, cubicweb-server (= ${source:Version}), cubicweb-twisted (= ${source:Version})
Recommends: postgresql | mysql | sqlite3
Description: the complete CubicWeb framework
 CubicWeb is a semantic web application framework.
 .
 This package will install all the components you need to run cubicweb on
 a single machine. You can also deploy cubicweb by running the different
 process on different computers, in which case you need to install the
 corresponding packages on the different hosts.


Package: cubicweb-server
Architecture: all
XB-Python-Version: ${python:Versions}
Conflicts: cubicweb-multisources
Replaces: cubicweb-multisources
Provides: cubicweb-multisources
Depends: ${misc:Depends}, ${python:Depends}, cubicweb-common (= ${source:Version}), cubicweb-ctl (= ${source:Version}), python-logilab-database (>= 1.8.2), cubicweb-postgresql-support | cubicweb-mysql-support | python-pysqlite2, python-passlib
Recommends: pyro (<< 4.0.0), cubicweb-documentation (= ${source:Version})
Suggests: python-zmq
Description: server part of the CubicWeb framework
 CubicWeb is a semantic web application framework.
 .
 This package provides the repository server part of the system.
 .
 This package provides the repository server part of the library and
 necessary shared data files such as the schema library.

Package: cubicweb-postgresql-support
Architecture: all
# postgresql-client packages for backup/restore of non local database
Depends: ${misc:Depends}, python-psycopg2, postgresql-client
Description: postgres support for the CubicWeb framework
 CubicWeb is a semantic web application framework.
 .
 This virtual package provides dependencies to use postgres for the
 cubicweb repository.

Package: cubicweb-mysql-support
Architecture: all
# mysql-client packages for backup/restore of non local database
Depends: ${misc:Depends}, python-mysqldb, mysql-client
Description: mysql support for the CubicWeb framework
 CubicWeb is a semantic web application framework.
 .
 This virtual package provides dependencies to use mysql for the
 cubicweb repository.


Package: cubicweb-twisted
Architecture: all
XB-Python-Version: ${python:Versions}
Provides: cubicweb-web-frontend
Depends: ${misc:Depends}, ${python:Depends}, cubicweb-web (= ${source:Version}), cubicweb-ctl (= ${source:Version}), python-twisted-web
Recommends: pyro (<< 4.0.0), cubicweb-documentation (= ${source:Version})
Description: twisted-based web interface for the CubicWeb framework
 CubicWeb is a semantic web application framework.
 .
 This package provides a twisted based HTTP server to serve
 the adaptative web interface (see cubicweb-web package).
 .
 This package provides only the twisted server part of the library.


Package: cubicweb-web
Architecture: all
XB-Python-Version: ${python:Versions}
Depends: ${misc:Depends}, ${python:Depends}, cubicweb-common (= ${source:Version}), python-simplejson (>= 2.0.9)
Recommends: python-docutils (>= 0.6), python-vobject, fckeditor, python-fyzz, python-imaging, python-rdflib
Description: web interface library for the CubicWeb framework
 CubicWeb is a semantic web application framework.
 .
 This package provides an adaptative web interface to the CubicWeb server.
 Install the cubicweb-twisted package to serve this interface via HTTP.
 .
 This package provides the web interface part of the library and
 necessary shared data files such as defaut views, images...


Package: cubicweb-common
Architecture: all
XB-Python-Version: ${python:Versions}
Depends: ${misc:Depends}, ${python:Depends}, graphviz, gettext, python-logilab-mtconverter (>= 0.8.0), python-logilab-common (>= 0.58.0), python-yams (>= 0.34.0), python-rql (>= 0.31.2), python-lxml
Recommends: python-simpletal (>= 4.0), python-crypto
Conflicts: cubicweb-core
Replaces: cubicweb-core
Description: common library for the CubicWeb framework
 CubicWeb is a semantic web application framework.
 .
 This package provides the common parts of the library used by both server
 code and web application code.


Package: cubicweb-ctl
Architecture: all
XB-Python-Version: ${python:Versions}
Depends: ${misc:Depends}, ${python:Depends}, cubicweb-common (= ${source:Version})
Description: tool to manage the CubicWeb framework
 CubicWeb is a semantic web application framework.
 .
 This package provides a control script to manage (create, upgrade, start,
 stop, etc) CubicWeb applications. It also include the init.d script
 to automatically start and stop CubicWeb applications on boot or shutdown.


Package: cubicweb-dev
Architecture: all
XB-Python-Version: ${python:Versions}
Depends: ${misc:Depends}, ${python:Depends}, cubicweb-server (= ${source:Version}), cubicweb-web (= ${source:Version}), python-pysqlite2
Suggests: w3c-dtd-xhtml, xvfb
Description: tests suite and development tools for the CubicWeb framework
 CubicWeb is a semantic web application framework.
 .
 This package provides the CubicWeb tests suite and some development tools
 helping in the creation of application.


Package: cubicweb-documentation
Architecture: all
Recommends: doc-base
Description: documentation for the CubicWeb framework
 CubicWeb is a semantic web application framework.
 .
 This package provides the system's documentation.