debian/cubicweb-server.postinst
author Denis Laxalde <denis.laxalde@logilab.fr>
Fri, 20 Nov 2015 14:17:46 +0100
changeset 10900 d666c9386b58
parent 0 b97547f5f1fa
permissions -rw-r--r--
[test/tox] Enforce installation of modified yapps 580a6821713d is not enough for tox apparently... The thing is that it will first install dependencies (the `deps` option from tox.ini), actually pulling yapps from Logilab github but then, it will install the project (that is, CubicWeb) from the sdist *along with its dependencies*, which will pull yapps again and override the previously installed version for some mysterious reason. So add a `pip install` command in tox.ini, so that the modified yapps is the last one installed.

#! /bin/sh -e

if [ -x "/etc/init.d/cubicweb-ctl" ]; then
    invoke-rc.d cubicweb-ctl restart || true
fi
 
 
#DEBHELPER#
 
exit 0