Add an import redirect hook from "cubes.<name>" to "cubicweb_<name>"
The hook consists of a finder and a loader implemented following PEP-302; it
is responsible for loading cubes distributed as packages (i.e. installed as
``cubicweb_<name>`` in site-packages) but imported (in client code) as ``from
cubes.<name> import ...``. So this is a transitional mechanism allowing cubes
following the new layout to be used by old-style cubes/applications.
The importer is installed upon calling CubicWebConfiguration's
cls_adjust_sys_path method (also called in cubicweb.devtools.__init__.py,
which is a prerequisite for importing any "legacy" cube. The loading of
old-style cubes is still handled by the CubicWeb configuration, based on
adjustment of sys.path etc.
Related to #13001466.
usr/lib/python2*/*-packages/cubicweb/devtools/
usr/lib/python2*/*-packages/cubicweb/skeleton/
usr/lib/python2*/*-packages/cubicweb/test
usr/lib/python2*/*-packages/cubicweb/dataimport/test
usr/lib/python2*/*-packages/cubicweb/entities/test
usr/lib/python2*/*-packages/cubicweb/ext/test
usr/lib/python2*/*-packages/cubicweb/server/test
usr/lib/python2*/*-packages/cubicweb/sobjects/test
usr/lib/python2*/*-packages/cubicweb/hooks/test
usr/lib/python2*/*-packages/cubicweb/web/test
usr/lib/python2*/*-packages/cubicweb/etwist/test