[views] Replace poorly named "invisible" class with "list-unstyled"
"li.invisible" actually means "hide bullet". Use a reasonable name
instead, such as bootstrap's "list-unstyled" class.
This patch also changes the DOM element the class is applied to.
"li.invisible" had to be enabled on every "li" tag, whereas the
"list-unstyled" class only needs to be applied to the parent "ul"
element.
from StringIO import StringIO
from logilab.common.testlib import TestCase, unittest_main
from cubicweb import dataimport
class UcsvreaderTC(TestCase):
def test_empty_lines_skipped(self):
stream = StringIO('''a,b,c,d,
1,2,3,4,
,,,,
,,,,
''')
self.assertEqual([[u'a', u'b', u'c', u'd', u''],
[u'1', u'2', u'3', u'4', u''],
],
list(dataimport.ucsvreader(stream)))
stream.seek(0)
self.assertEqual([[u'a', u'b', u'c', u'd', u''],
[u'1', u'2', u'3', u'4', u''],
[u'', u'', u'', u'', u''],
[u'', u'', u'', u'', u'']
],
list(dataimport.ucsvreader(stream, skip_empty=False)))
if __name__ == '__main__':
unittest_main()