debian/cubicweb-documentation.postinst
author Adrien Di Mascio <Adrien.DiMascio@logilab.fr>
Mon, 04 Jan 2010 18:58:35 +0100
branchstable
changeset 4206 cebdf8ee5ad7
parent 0 b97547f5f1fa
permissions -rw-r--r--
[forms] edited_entity must be set before calling session_key() EntityFieldsForm.__init__ calls FieldsForm.__init__ which in turn calls self.session_key(). self.session_key() uses self.edited_key to compute the correct session key. We thus need edited_entity to be set **before** calling super's __init__. The bug only occured when EntityFieldsForm was selected because of its one_line_rset() selector instead of match_kwargs('entity').

#! /bin/sh -e
#

if [ "$1" = configure ]; then
  if which install-docs >/dev/null 2>&1; then
    install-docs -i /usr/share/doc-base/cubicweb-doc
  fi
fi


#DEBHELPER#

exit 0