debian/cubicweb-ctl.postinst
author Samuel Trégouët <samuel.tregouet@logilab.fr>
Mon, 21 Dec 2015 12:16:12 +0100
changeset 11020 c8c8f6a6147f
parent 10559 5821ae654dfd
permissions -rw-r--r--
[dataimport] massive_store: drop all constraints in __init__ and restore all in finish This should avoid dependency issues when dropping specific constraints (e.g. when dropping a primary constraint referenced by a foreign key constraint). We only do this in master mode, slave mode stores are supposed to work with an initialized db already.

#! /bin/sh -e

case "$1" in
    configure|abort-upgrade|abort-remove|abort-deconfigure)
        update-rc.d cubicweb defaults 99 >/dev/null
    ;;
    *)
        echo "postinst called with unknown argument \`$1'" >&2
        exit 1
    ;;
esac

#DEBHELPER#

exit 0