debian/cubicweb-common.postinst
author Sylvain <syt@logilab.fr>
Fri, 19 Dec 2008 17:04:35 +0100
changeset 243 c718f6495ace
parent 233 cd2f4ef6af37
permissions -rw-r--r--
Added tag cubicweb-version-2_99_6 for changeset 5b58fd1aba50

#! /bin/sh -e

if [ "$1" = configure ]; then
    # XXX bw compat: erudi -> cubicweb migration
    if [ -e "/usr/share/erudi/templates/" ]; then
      # skip the "shared" subdirectory by moving it first, restoring it later
      mv /usr/share/erudi/templates/shared /usr/share/erudi/
      mv /usr/share/erudi/templates/* /usr/share/cubicweb/cubes/
      mv /usr/share/erudi/shared /usr/share/erudi/templates
      echo 'moved /usr/share/erudi/templates/* to /usr/share/cubicweb/cubes/'
    fi
fi 
#DEBHELPER#
 
exit 0