debian/tests/skeleton-packaging
author Nicola Spanti <nicola.spanti@logilab.fr>
Fri, 13 Apr 2018 17:28:14 +0200
changeset 12787 be63e0fd43d0
parent 12709 280c9db41038
permissions -rw-r--r--
[web/views] Fix AutoformSectionRelationTags.set_muledit_editable It is a method call, so `self` is passed implicitely as first argument, so it is useless to pass it also explicitely as second argument. In fact, it does not work without this. A monkey patch had been done in a private client's project, but the fix is revelant for everyone.

#!/bin/sh

set -e
set -x

if [ -z "$AUTOPKGTEST_TMP" ]; then
	echo "Not running as part as autopkgtest" >&2
	exit 250
fi

# Switch to unprivileged user if needed
if [ "$(id -u)" = 0 ]; then
	apt-get install -q -y sudo
	echo 'Defaults !fqdn' > /etc/sudoers.d/fqdn
	echo 'nobody ALL=(ALL) NOPASSWD: ALL' > /etc/sudoers.d/nobody
	chown nobody:nogroup "$AUTOPKGTEST_TMP"
	exec su nobody -s /bin/sh -c "$0"
fi

cd "$AUTOPKGTEST_TMP"

# Create a cube
PACKAGE="cubicweb-mytest"
cubicweb-ctl newcube -s 'Just a test cube' ${PACKAGE#cubicweb-}
cd "$PACKAGE"

UPSTREAM_VERSION=$(python3 setup.py --version)
DEBIAN_VERSION=$(dpkg-parsechangelog -S Version)

# Create source tarball
python3 setup.py sdist
mv "dist/${PACKAGE}-${UPSTREAM_VERSION}.tar.gz" "../${PACKAGE}_${UPSTREAM_VERSION}.orig.tar.gz"

# Install build-dependencies
mk-build-deps --install --root-cmd sudo --remove \
	--tool 'apt-get -o Debug::pkgProblemResolver=yes --no-install-recommends --quiet --assume-yes'

# Build!
dpkg-buildpackage

# Output .buildinfo for posterity
cat ../*.buildinfo

# Output package content, again for posterity
debc

# Install the package
sudo debi --with-depends

lintian -i ../*.dsc ../*.changes

# Test if Python module is usable
python3 -c 'import cubicweb_mytest; print(dir(cubicweb_mytest))'

# Run autopkgtest (uh… inception, anyone?)
sudo autopkgtest ../*.changes -- null