skeleton/debian/rules.tmpl
author Adrien Di Mascio <Adrien.DiMascio@logilab.fr>
Fri, 29 Apr 2011 12:34:53 +0200
changeset 7284 a474cb989546
parent 5334 7da1a6ca8f65
child 8098 e80edd022901
permissions -rwxr-xr-x
[js] make _loadAjaxHtmlHead aware of mod_concat-like urls _loadAjaxHtmlHead keeps track of already imported resources (js / css) to make sure they're not included twice, but with mod_concat-like urls, things get a bit more complicated : if BASE_URL/data??foo.js,bar.js is already imported, then loading : BASE_URL/data??bar.js,spam.js should only load spam.js

#!/usr/bin/make -f
# Sample debian/rules that uses debhelper.
# GNU copyright 1997 to 1999 by Joey Hess.

# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
build: build-stamp
build-stamp:
	dh_testdir
	NO_SETUPTOOLS=1 python setup.py -q build
	touch build-stamp

clean:
	dh_testdir
	dh_testroot
	rm -f build-stamp configure-stamp
	rm -rf build
	find . -name "*.pyc" | xargs rm -f
	dh_clean

install: build
	dh_testdir
	dh_testroot
	dh_clean -k
	dh_installdirs -i
	NO_SETUPTOOLS=1 python setup.py -q install --no-compile --prefix=debian/%(distname)s/usr/
	# remove generated .egg-info file
	rm -rf debian/%(distname)s/usr/lib/python*


# Build architecture-independent files here.
binary-indep: build install
	dh_testdir
	dh_testroot
	dh_install -i
	dh_installchangelogs -i
	dh_installexamples -i
	dh_installdocs -i
	dh_installman -i
	dh_link -i
	dh_compress -i -X.py -X.ini -X.xml -Xtest
	dh_fixperms -i
	dh_installdeb -i
	dh_gencontrol -i
	dh_md5sums -i
	dh_builddeb -i


# Build architecture-dependent files here.
binary-arch:

binary: binary-indep
.PHONY: build clean binary-arch binary-indep binary