debian/cubicweb-twisted.postinst
author Julien Cristau <julien.cristau@logilab.fr>
Fri, 18 Jul 2014 12:23:01 +0200
changeset 9889 9b42e55e0686
parent 0 b97547f5f1fa
permissions -rw-r--r--
[web] Fix expiry of anonymous sessions (closes #4154479) Things like: try: foo except: bar else: baz doesn't work very well if you expect baz to run even in the exception case. Plus, session.cnx.check() is a dbapi remnant, so drop it and just look at session.mtime.

#! /bin/sh -e

if [ -x "/etc/init.d/cubicweb-ctl" ]; then
    invoke-rc.d cubicweb-ctl restart || true
fi
 
 
#DEBHELPER#
 
exit 0