[transaction] rename transaction_data to data
Transaction.transaction_data is redundant. A transaction_data property is left
for backward compatibility. Deprecation mechanism will come in later changeset
include *.pyinclude */*.pyrecursive-include data *.gif *.png *.ico *.css *.jsrecursive-include i18n *.porecursive-include wdoc *