debian/rules
author Denis Laxalde <denis@laxalde.org>
Wed, 29 Apr 2015 22:46:17 +0200
changeset 11575 97110b4af42f
parent 11515 b3267ba817b4
child 11631 faf279e33298
permissions -rwxr-xr-x
Handle absence of anonymous user Set cw_session and then cw_cnx request attributes to None in case anonymous connection is not allowed (i.e. no "anon" user in config). Then catch AuthenticationError in CubicWebPyramidHandler and return the 'login' view. Closes #4751862.

#!/usr/bin/make -f

.PHONY: build
build:
	dh $@ --with python2

%:
	dh $@ --with python2