Remove uses of logilab.common.compat.{all,any}
They're just aliases to the builtin ones on python 2.5+. If anyone needs
convincing:
>>> from logilab.common import compat
>>> compat.any
<built-in function any>
>>> compat.all
<built-in function all>
usr/lib/PY_VERSION/*-packages/cubicweb/entities/
usr/lib/PY_VERSION/*-packages/cubicweb/ext/
usr/share/cubicweb/cubes/
usr/lib/PY_VERSION/*-packages/cubicweb/*.py