[server] remove cnxset tracking, it is now unneeded
Indeed, all cnxsets will now be acquired using the following API::
with session.new_cnx() as cnx:
cnx.execute(...)
# do stuff
cnx.commit()
These well-scoped blocks are the only place a cnxset can be acquired.
The old use-case for un-delimited cnxsets (pyro/zmqpickle protocols)
have been removed.
The "mode" of connection objects becomes "write" forever (it will be
removed in a couple of changesets).
Related to #2919309.
#!/usr/bin/make -f
export NO_SETUPTOOLS=1
%:
dh $@ --with python2
override_dh_auto_install:
dh_auto_install
# remove generated .egg-info file
rm -rf debian/*/usr/lib/python*
override_dh_python2:
dh_python2 -i /usr/share/cubicweb