[server] remove cnxset tracking, it is now unneeded
Indeed, all cnxsets will now be acquired using the following API::
with session.new_cnx() as cnx:
cnx.execute(...)
# do stuff
cnx.commit()
These well-scoped blocks are the only place a cnxset can be acquired.
The old use-case for un-delimited cnxsets (pyro/zmqpickle protocols)
have been removed.
The "mode" of connection objects becomes "write" forever (it will be
removed in a couple of changesets).
Related to #2919309.
usr/lib/PY_VERSION/*-packages/cubicweb/devtools/
usr/lib/PY_VERSION/*-packages/cubicweb/skeleton/
usr/lib/PY_VERSION/*-packages/cubicweb/test
usr/lib/PY_VERSION/*-packages/cubicweb/entities/test
usr/lib/PY_VERSION/*-packages/cubicweb/ext/test
usr/lib/PY_VERSION/*-packages/cubicweb/server/test
usr/lib/PY_VERSION/*-packages/cubicweb/sobjects/test
usr/lib/PY_VERSION/*-packages/cubicweb/hooks/test
usr/lib/PY_VERSION/*-packages/cubicweb/web/test
usr/lib/PY_VERSION/*-packages/cubicweb/etwist/test