[server] remove cnxset tracking, it is now unneeded
Indeed, all cnxsets will now be acquired using the following API::
with session.new_cnx() as cnx:
cnx.execute(...)
# do stuff
cnx.commit()
These well-scoped blocks are the only place a cnxset can be acquired.
The old use-case for un-delimited cnxsets (pyro/zmqpickle protocols)
have been removed.
The "mode" of connection objects becomes "write" forever (it will be
removed in a couple of changesets).
Related to #2919309.
usr/bin/cubicweb-ctl usr/bin/
usr/lib/PY_VERSION/*-packages/cubicweb/cwctl.py
../cubicweb-ctl.bash_completion etc/bash_completion.d/cubicweb-ctl