cubicweb/skeleton/debian/tests/pytest
author Philippe Pepiot <ph@itsalwaysdns.eu>
Tue, 31 Mar 2020 16:17:14 +0200
changeset 12964 85f0fe1bb78b
parent 12709 280c9db41038
permissions -rw-r--r--
[server] move connection pooler initialization logic to get_cnxset() This avoid complex logic in Repository initialization.

#!/bin/sh

set -e
set -x

### Setup tests

# Uncomment if tests require database access
#service postgresql restart || service postgresql start
#trap 'service postgresql stop' EXIT

cp -r test tox.ini "$AUTOPKGTEST_TMP"
chown -R nobody:nogroup "$AUTOPKGTEST_TMP"

### Run tests

for py in $(py3versions -r 2>/dev/null); do
	cd "$AUTOPKGTEST_TMP"
	echo "Testing with $py:"
	su nobody --shell /bin/sh \
		-c "$py -m pytest -v"
done