debian/cubicweb-twisted.postinst
author Rémi Cardona <remi.cardona@logilab.fr>
Thu, 05 Jun 2014 17:41:14 +0200
branchstable
changeset 9921 8227358aa983
parent 0 b97547f5f1fa
permissions -rw-r--r--
[web] Return useful error messages when exceptions arise in ajax controllers (closes #3932503) The call to super() in RemoteCallException passes 'reason' all the way to python's Exception.__init__() which is then stored in Exception.args. This way, CubicWebPublisher.ajax_error_handler() gets a useful error message when calling unicode(exc). The change to uilib is just to prepend the exception type name. Just a small improvement.

#! /bin/sh -e

if [ -x "/etc/init.d/cubicweb-ctl" ]; then
    invoke-rc.d cubicweb-ctl restart || true
fi
 
 
#DEBHELPER#
 
exit 0