[pkg] Add new autopkgtest for skeleton packaging
When running `cubicweb-ctl newcube`, the generated template provides
debian packaging. So let's add automated tests for that using
autopkgtest.
The new test will generated a new cube, build a source tarball,
build the package, try to install it, see if the Python 3 module is
available and even run autopkgtest against the newly created packages.
Along the way it will also print information about the generated
package: buildinfo, package content, and lintian report.
Tests: unittest
Depends:
python3-cubicweb, cubicweb-ctl,
@builddeps@,
python3-pytest,
python3-flake8,
python3-psycopg2, postgresql, postgresql-plpython,
python3-ldap3, slapd, ldap-utils
Restrictions: allow-stderr, isolation-container
Tests: skeleton-packaging
Depends:
python3-cubicweb, cubicweb-ctl,
python3-pyramid, python3-wsgicors,
devscripts, equivs, lintian, autopkgtest
Restrictions: allow-stderr, needs-root