debian/control
author Julien Jehannet <Julien Jehannet <julien.jehannet@logilab.fr>>
Tue, 02 Mar 2010 21:48:36 +0100
branchstable
changeset 4783 6dc34d4cf892
parent 4733 022290f7503d
child 4819 b02f862c7188
permissions -rw-r--r--
[F] views: fix 2 unicode errors 1. You can now use valid unicode strings in ValidationError exception. Previously, if 'err' contains unicode, UnicodeDecodeError was raised by format_errors() >>> templstr = '<li>%s</li>\n' >>> e = ValidationError(None, {None: u'oué, une exception en unicode!'}) >>> templstr % e '<li>None (None): ou\xc3\xa9, une exception en unicode!</li>\n' >>> templstr = u'<li>%s</li>\n' >>> templstr % e u'<li>None (None): ou\xe9, une exception en unicode!</li>\n' 2. The message of an Exception can contains unicode. But it now properly managed by “informal” string representation. We can easily fix the problem by using the Exception.message attribute that still contains the original message. >>> a = AssertionError(u'séfdsdf') >>> a.message u's\xe9fdsdf' >>> str(a) Traceback (most recent call last): File "<stdin>", line 1, in <module> UnicodeEncodeError: 'ascii' codec can't encode character u'\xe9' in position 1: ordinal not in range(128) >>> a = ValueError(u'fsdfsdéfsdfs') >>> str(a) Traceback (most recent call last): File "<stdin>", line 1, in <module> UnicodeEncodeError: 'ascii' codec can't encode character u'\xe9' in position 6: ordinal not in range(128) >>> a ValueError(u'fsdfsd\xe9fsdfs',) >>> unicode(a) Traceback (most recent call last): File "<stdin>", line 1, in <module> UnicodeEncodeError: 'ascii' codec can't encode character u'\xe9' in position 6: ordinal not in range(128) >>> a.message u'fsdfsd\xe9fsdfs'

Source: cubicweb
Section: web
Priority: optional
Maintainer: Logilab S.A. <contact@logilab.fr>
Uploaders: Sylvain Thenault <sylvain.thenault@logilab.fr>,
           Julien Jehannet <julien.jehannet@logilab.fr>,
           Adrien Di Mascio <Adrien.DiMascio@logilab.fr>,
           Aurélien Campéas <aurelien.campeas@logilab.fr>,
           Nicolas Chauvat <nicolas.chauvat@logilab.fr>
Build-Depends: debhelper (>= 5), python-dev (>=2.4), python-central (>= 0.5)
Standards-Version: 3.8.0
Homepage: http://www.cubicweb.org
XS-Python-Version: >= 2.4, << 2.6

Package: cubicweb
Architecture: all
XB-Python-Version: ${python:Versions}
Depends: ${python:Depends}, cubicweb-server (= ${source:Version}), cubicweb-twisted (= ${source:Version})
XB-Recommends: (postgresql, postgresql-plpython, postgresql-contrib) | mysql | sqlite3
Recommends: postgresql | mysql | sqlite3
Description: the complete CubicWeb framework
 CubicWeb is a semantic web application framework.
 .
 This package will install all the components you need to run cubicweb on
 a single machine. You can also deploy cubicweb by running the different
 process on different computers, in which case you need to install the
 corresponding packages on the different hosts.


Package: cubicweb-server
Architecture: all
XB-Python-Version: ${python:Versions}
Conflicts: cubicweb-multisources
Replaces: cubicweb-multisources
Provides: cubicweb-multisources
Depends: ${python:Depends}, cubicweb-common (= ${source:Version}), cubicweb-ctl (= ${source:Version}), python-indexer (>= 0.6.1), python-psycopg2 | python-mysqldb | python-pysqlite2
Recommends: pyro, cubicweb-documentation (= ${source:Version})
Description: server part of the CubicWeb framework
 CubicWeb is a semantic web application framework.
 .
 This package provides the repository server part of the system.
 .
 This package provides the repository server part of the library and
 necessary shared data files such as the schema library.


Package: cubicweb-twisted
Architecture: all
XB-Python-Version: ${python:Versions}
Provides: cubicweb-web-frontend
Depends: ${python:Depends}, cubicweb-web (= ${source:Version}), cubicweb-ctl (= ${source:Version}), python-twisted-web2
Recommends: pyro, cubicweb-documentation (= ${source:Version})
Description: twisted-based web interface for the CubicWeb framework
 CubicWeb is a semantic web application framework.
 .
 This package provides a twisted based HTTP server to serve
 the adaptative web interface (see cubicweb-web package).
 .
 This package provides only the twisted server part of the library.


Package: cubicweb-web
Architecture: all
XB-Python-Version: ${python:Versions}
Depends: ${python:Depends}, cubicweb-common (= ${source:Version}), python-simplejson (>= 1.3), python-elementtree
Recommends: python-docutils, python-vobject, fckeditor, python-fyzz, python-pysixt, fop, python-imaging
Description: web interface library for the CubicWeb framework
 CubicWeb is a semantic web application framework.
 .
 This package provides an adaptative web interface to the CubicWeb server.
 Install the cubicweb-twisted package to serve this interface via HTTP.
 .
 This package provides the web interface part of the library and
 necessary shared data files such as defaut views, images...


Package: cubicweb-common
Architecture: all
XB-Python-Version: ${python:Versions}
Depends: ${python:Depends}, graphviz, gettext, python-logilab-mtconverter (>= 0.6.0), python-logilab-common (>= 0.48.1), python-yams (>= 0.28.0), python-rql (>= 0.24.0), python-lxml
Recommends: python-simpletal (>= 4.0), python-crypto
Conflicts: cubicweb-core
Replaces: cubicweb-core
Description: common library for the CubicWeb framework
 CubicWeb is a semantic web application framework.
 .
 This package provides the common parts of the library used by both server
 code and web application code.


Package: cubicweb-ctl
Architecture: all
XB-Python-Version: ${python:Versions}
Depends: ${python:Depends}, cubicweb-common (= ${source:Version})
Description: tool to manage the CubicWeb framework
 CubicWeb is a semantic web application framework.
 .
 This package provides a control script to manage (create, upgrade, start,
 stop, etc) CubicWeb applications. It also include the init.d script
 to automatically start and stop CubicWeb applications on boot or shutdown.


Package: cubicweb-dev
Architecture: all
XB-Python-Version: ${python:Versions}
Depends: ${python:Depends}, cubicweb-server (= ${source:Version}), cubicweb-web (= ${source:Version}), python-pysqlite2
Suggests: w3c-dtd-xhtml
Description: tests suite and development tools for the CubicWeb framework
 CubicWeb is a semantic web application framework.
 .
 This package provides the CubicWeb tests suite and some development tools
 helping in the creation of application.


Package: cubicweb-documentation
Architecture: all
Recommends: doc-base
Description: documentation for the CubicWeb framework
 CubicWeb is a semantic web application framework.
 .
 This package provides the system's documentation.