debian/rules
author Christophe de Vienne <christophe@unlish.com>
Thu, 23 Oct 2014 17:30:15 +0200
changeset 11643 63d2c01fcb94
parent 11632 b05f361db666
child 11653 18939907a115
permissions -rw-r--r--
Added tag cubicweb-pyramid-version-0.1.0, cubicweb-pyramid-debian-version-0.1.0-1 for changeset 3defbb0f147a

#!/usr/bin/make -f
# Sample debian/rules that uses debhelper.
# GNU copyright 1997 to 1999 by Joey Hess.

# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
build: build-arch build-indep
build-arch:
	# Nothing to do
build-indep: build-stamp
build-stamp:
	dh_testdir
	NO_SETUPTOOLS=1 python setup.py -q build
	touch build-stamp

clean:
	dh_testdir
	rm -f build-stamp configure-stamp
	rm -rf build
	find . -name "*.pyc" -delete
	dh_clean

install: build
	dh_testdir
	dh_testroot
	dh_clean -k
	dh_installdirs -i
	NO_SETUPTOOLS=1 python setup.py -q install --no-compile --prefix=debian/cubicweb-pyramid/usr/
	# remove generated .egg-info file
	rm -rf debian/cubicweb-pyramid/usr/lib/python*


# Build architecture-independent files here.
binary-indep: build install
	dh_testdir
	dh_testroot
	dh_install -i
	dh_installchangelogs -i
	dh_installexamples -i
	dh_installdocs -i README
	dh_installman -i
	dh_pysupport -i /usr/share/cubicweb
	dh_link -i
	dh_compress -i -X.py -X.ini -X.xml -Xtest
	dh_fixperms -i
	dh_installdeb -i
	dh_gencontrol -i
	dh_md5sums -i
	dh_builddeb -i


# Build architecture-dependent files here.
binary-arch:

binary: binary-indep
.PHONY: build clean binary-arch binary-indep binary