debian/cubicweb-twisted.postinst
author Aurelien Campeas <aurelien.campeas@logilab.fr>
Thu, 12 Jun 2014 15:54:44 +0200
changeset 11195 5de859b95988
parent 0 b97547f5f1fa
permissions -rw-r--r--
[session, repository] deprecate repo.connect and move .close reponsibility to session object Repository.new_session just returns a plain session object, and `.connect` (which returns a sessionid) is deprecated. For .close:: session.close() # done ! The session will bear the responsibility to call the "session_close" event but that's better than the previous idiom:: repo.close(session.sessionid) which involves both objects. Related to #1381328. Related to #2919309.

#! /bin/sh -e

if [ -x "/etc/init.d/cubicweb-ctl" ]; then
    invoke-rc.d cubicweb-ctl restart || true
fi
 
 
#DEBHELPER#
 
exit 0