[crypto] Use Cryptodome namespace instead of Crypto
PyCryptodome comes in two flavors: “an almost drop-in replacement for the old
PyCrypto library” and “a library independent of the old PyCrypto”. The former
uses the Crypto namespace, and is shipped as `pycryptodome` while the latter
uses Cryptodome instead and lies in the `pycryptodomex` package.
Given the reason to switch to PyCryptodome is that PyCrypto in unmaintained,
its probably better to avoid any mistake and mandate the specific usage of
the Cryptodome namespace by requiring `pycryptodomex` instead of
`pycryptodome`.
A more present reason is that Debian buster will only provide a package
with the separate namespace flavor. The current Recommends is not working with
the current code. Although it's important to note that the package name will
probably have to be changed to `python3-pycryptodomex` once
https://bugs.debian.org/886291 is solved.
Source: cubicweb
Section: web
Priority: optional
Maintainer: Logilab S.A. <contact@logilab.fr>
Uploaders: Sylvain Thenault <sylvain.thenault@logilab.fr>,
David Douard <david.douard@logilab.fr>,
Build-Depends:
debhelper (>= 9.20160709),
dh-python,
python3-all,
python3-setuptools,
python3-docutils,
python3-sphinx,
python3-logilab-common (>= 1.4.0),
python3-logilab-mtconverter,
python3-markdown,
python3-tz,
python3-rql (>= 0.34.0),
python3-yams (>= 0.45.0),
python3-lxml,
python3-setuptools,
python3-pyramid,
python3-pyramid-multiauth,
python3-waitress,
python3-passlib,
python3-repoze.lru,
python3-wsgicors,
python3-filelock,
sphinx-common,
Standards-Version: 4.3.0
Homepage: https://www.cubicweb.org
X-Python3-Version: >= 3.4
Package: python3-cubicweb
Architecture: all
Depends:
${misc:Depends},
${python3:Depends},
graphviz,
gettext,
Recommends:
cubicweb-ctl (= ${source:Version}),
python3-cubicweb-postgresql-support (= ${source:Version})
| sqlite3,
# pyramid recommends
python3-pyramid (>= 1.5.0),
python3-pyramid-multiauth,
python3-waitress (>= 0.8.9),
python3-wsgicors,
python3-repoze.lru,
# common recommends
python3-simpletal (>= 4.0),
python3-pycryptodome,
# web recommends (mostly)
python3-docutils (>= 0.6),
python3-vobject,
fckeditor,
python3-fyzz,
python3-imaging,
python3-rdflib,
python3-werkzeug,
# dev recommends
python3-pysqlite2,
Suggests:
python3-zmq,
python3-cwclientlib (>= 0.4.0),
python3-cubicweb-documentation (= ${source:Version}),
w3c-dtd-xhtml,
xvfb,
python3-pyramid-debugtoolbar,
Replaces:
cubicweb (<< 3.24.0-1~),
cubicweb-server (<< 3.24.0-1~),
cubicweb-web (<< 3.24.0-1~),
cubicweb-core,
cubicweb-common (<< 3.24.0-1~),
Breaks:
cubicweb (<< 3.24.0-1~),
cubicweb-server (<< 3.24.0-1~),
cubicweb-inlinedit (<< 1.1.1),
cubicweb-bootstrap (<< 0.6.6),
cubicweb-folder (<< 1.10.0),
cubicweb-web (<< 3.24.0-1~),
cubicweb-comment (<< 1.9.1),
cubicweb-person (<< 1.8.0),
cubicweb-geocoding (<< 0.2.0),
cubicweb-invoice (<< 0.6.1),
cubicweb-mercurial-server (<< 0.4.2),
cubicweb-forgotpwd (<< 0.4.3),
cubicweb-registration (<< 0.4.3),
cubicweb-vcsfile (<< 1.15.0),
cubicweb-bootstrap (<< 0.6),
cubicweb-common (<< 3.24.0-1~),
Provides:
cubicweb,
cubicweb-server,
cubicweb-web-frontend,
cubicweb-web,
cubicweb-common,
Conflicts:
cubicweb-multisources,
cubicweb-core,
Description: the complete CubicWeb framework
CubicWeb is a semantic web application framework.
.
This metapackage will install all the components you need to run cubicweb on a
single machine. You can also deploy cubicweb by running the different process
on different computers, in which case you need to install the corresponding
packages on the different hosts.
Package: python3-cubicweb-postgresql-support
Architecture: all
# postgresql-client packages for backup/restore of non local database
Replaces: cubicweb-postgresql-support (<< 3.24.0-1~)
Breaks: cubicweb-postgresql-support (<< 3.24.0-1~)
Provides: cubicweb-postgresql-support
Depends:
${misc:Depends},
python3-cubicweb (= ${source:Version}),
python3-psycopg2,
postgresql-client
Description: postgres support for the CubicWeb framework
CubicWeb is a semantic web application framework.
.
This dependency package provides dependencies to use PostgreSQL for the
cubicweb repository.
Package: cubicweb-ctl
Architecture: all
Depends:
${misc:Depends},
python3-cubicweb (= ${source:Version})
Description: tool to manage the CubicWeb framework
CubicWeb is a semantic web application framework.
.
This package provides a control script to manage (create, upgrade, start,
stop, etc) CubicWeb applications. It also include the init.d script
to automatically start and stop CubicWeb applications on boot or shutdown.
Package: python3-cubicweb-documentation
Architecture: all
Section: doc
Replaces: cubicweb-documentation (<< 3.24.0-1~)
Breaks: cubicweb-documentation (<< 3.24.0-1~)
Provides: cubicweb-documentation
Conflicts: python-cubicweb-documentation
Depends:
${misc:Depends},
${sphinxdoc:Depends},
Built-Using: ${sphinxdoc:Built-Using}
Recommends:
doc-base
Description: documentation for the CubicWeb framework
CubicWeb is a semantic web application framework.
.
This package provides the system's documentation.
# Transitional packages after renaming of (most) binary packages
Package: cubicweb
Architecture: all
Priority: optional
Section: oldlibs
Depends:
python3-cubicweb, ${misc:Depends}
Description: transitional package
This is a transitional package. It can safely be removed.
Package: cubicweb-server
Architecture: all
Priority: optional
Section: oldlibs
Depends:
python3-cubicweb, ${misc:Depends}
Description: transitional package
This is a transitional package. It can safely be removed.
Package: cubicweb-postgresql-support
Architecture: all
Priority: optional
Section: oldlibs
Depends:
python3-cubicweb-postgresql-support, ${misc:Depends}
Description: transitional package
This is a transitional package. It can safely be removed.
Package: cubicweb-web
Architecture: all
Priority: optional
Section: oldlibs
Depends:
python3-cubicweb, ${misc:Depends}
Description: transitional package
This is a transitional package. It can safely be removed.
Package: cubicweb-common
Architecture: all
Priority: optional
Section: oldlibs
Depends:
python3-cubicweb, ${misc:Depends}
Description: transitional package
This is a transitional package. It can safely be removed.
Package: cubicweb-dev
Architecture: all
Priority: optional
Section: oldlibs
Depends:
python3-cubicweb, ${misc:Depends}
Description: transitional package
This is a transitional package. It can safely be removed.
Package: cubicweb-documentation
Architecture: all
Priority: optional
Section: oldlibs
Depends:
python3-cubicweb-documentation, ${misc:Depends}
Description: transitional package
This is a transitional package. It can safely be removed.