skeleton/debian/rules
author Julien Cristau <julien.cristau@logilab.fr>
Wed, 28 Oct 2015 17:39:30 +0000
changeset 10802 3d948d35d94f
parent 10795 839ea43f4d5b
permissions -rwxr-xr-x
[migration] re-try without print_function when compiling a script fails As part of the python3 porting we added the __future__.print_function import to cubicweb.migration. That started affecting all migration scripts it runs, which may not be prepared. So if compiling a script results in SyntaxError, try again without the print_function flag. Closes #7935030

#!/usr/bin/make -f

export NO_SETUPTOOLS=1

%:
	dh $@ --with python2

override_dh_python2:
	dh_python2 -i /usr/share/cubicweb