debian/cubicweb-twisted.postinst
author Julien Cristau <julien.cristau@logilab.fr>
Wed, 28 Oct 2015 17:39:30 +0000
changeset 10802 3d948d35d94f
parent 0 b97547f5f1fa
permissions -rw-r--r--
[migration] re-try without print_function when compiling a script fails As part of the python3 porting we added the __future__.print_function import to cubicweb.migration. That started affecting all migration scripts it runs, which may not be prepared. So if compiling a script results in SyntaxError, try again without the print_function flag. Closes #7935030

#! /bin/sh -e

if [ -x "/etc/init.d/cubicweb-ctl" ]; then
    invoke-rc.d cubicweb-ctl restart || true
fi
 
 
#DEBHELPER#
 
exit 0