Avoid to update inlined relation column to NULL when deleting entities
When deleting entities, cubicweb run a rql DELETE on all relations to trigger hooks.
For an inlined relation this also mean set the column to NULL. This operation
may fail if there's additional constraints on the column.
Also this is a weird and useless behavior since deleting the entity row will by
definition delete the relation.
We still doesn't handle the case where both subject and object are going to be
deleted because rows need to be deleted in a particular order that cubicweb
doesn't handle.
Add a test checking UPDATE does not occur but hooks are correctly called.
Closes #17236690
Source: cubicweb
Section: web
Priority: optional
Maintainer: Logilab S.A. <contact@logilab.fr>
Uploaders: Sylvain Thenault <sylvain.thenault@logilab.fr>,
David Douard <david.douard@logilab.fr>,
Build-Depends:
debhelper (>= 9.20160709),
dh-python,
python-all,
python-setuptools,
python-sphinx,
python3-all,
python3-setuptools,
python3-sphinx,
Standards-Version: 3.9.6
Homepage: https://www.cubicweb.org
X-Python-Version: >= 2.7
X-Python3-Version: >= 3.4
Package: python-cubicweb
Architecture: all
Section: python
Depends:
${misc:Depends},
${python:Depends},
python-six (>= 1.4.0),
python-logilab-mtconverter (>= 0.8.0),
python-logilab-common (>= 1.4.0),
python-logilab-database (>= 1.15.0),
python-yams (>= 0.45.0),
python-rql (>= 0.34.0),
python-unittest2 (>= 0.7.0),
python-lxml,
python-markdown,
python-passlib,
python-tz,
graphviz,
gettext,
Recommends:
cubicweb-ctl (= ${source:Version}),
python-cubicweb-postgresql-support (= ${source:Version})
| sqlite3,
python-cubicweb-pyramid (= ${source:Version}),
# common recommends
python-simpletal (>= 4.0),
python-crypto,
# web recommends (mostly)
python-docutils (>= 0.6),
python-vobject,
fckeditor,
python-fyzz,
python-imaging,
python-rdflib,
python-werkzeug,
# dev recommends
python-pysqlite2,
Suggests:
python-zmq,
python-cwclientlib (>= 0.4.0),
python-cubicweb-twisted (= ${source:Version}),
python-cubicweb-documentation (= ${source:Version}),
w3c-dtd-xhtml,
xvfb,
Replaces:
cubicweb (<< 3.24.0-1~),
cubicweb-server (<< 3.24.0-1~),
cubicweb-twisted (<< 3.24.0-1~),
cubicweb-web (<< 3.24.0-1~),
cubicweb-core,
cubicweb-common (<< 3.24.0-1~),
Breaks:
cubicweb (<< 3.24.0-1~),
cubicweb-server (<< 3.24.0-1~),
cubicweb-twisted (<< 3.24.0-1~),
cubicweb-inlinedit (<< 1.1.1),
cubicweb-bootstrap (<< 0.6.6),
cubicweb-folder (<< 1.10.0),
cubicweb-web (<< 3.24.0-1~),
cubicweb-comment (<< 1.9.1),
cubicweb-person (<< 1.8.0),
cubicweb-geocoding (<< 0.2.0),
cubicweb-invoice (<< 0.6.1),
cubicweb-mercurial-server (<< 0.4.2),
cubicweb-forgotpwd (<< 0.4.3),
cubicweb-registration (<< 0.4.3),
cubicweb-vcsfile (<< 1.15.0),
cubicweb-bootstrap (<< 0.6),
cubicweb-common (<< 3.24.0-1~),
Provides:
cubicweb,
cubicweb-server,
cubicweb-web-frontend,
cubicweb-web,
cubicweb-common,
Conflicts:
cubicweb-multisources,
cubicweb-core,
Description: CubicWeb framework (Python 2)
CubicWeb is a semantic web application framework.
.
This metapackage will install all the components you need to run cubicweb on a
single machine. You can also deploy cubicweb by running the different process
on different computers, in which case you need to install the corresponding
packages on the different hosts.
Package: python3-cubicweb
Architecture: all
Section: python
Depends:
${misc:Depends},
${python3:Depends},
python3-six (>= 1.4.0),
python3-logilab-mtconverter (>= 0.8.0),
python3-logilab-common (>= 1.4.0),
python3-logilab-database (>= 1.15.0),
python3-yams (>= 0.45.0),
python3-rql (>= 0.34.0),
python3-unittest2 (>= 0.7.0),
python3-lxml,
python3-markdown,
python3-passlib,
python3-tz,
graphviz,
gettext,
Recommends:
cubicweb-ctl3 (= ${source:Version}),
python3-cubicweb-postgresql-support (= ${source:Version})
| sqlite3,
python3-cubicweb-pyramid (= ${source:Version}),
# common recommends
python3-simpletal (>= 4.0),
python3-crypto,
# web recommends (mostly)
python3-docutils (>= 0.6),
python3-vobject,
fckeditor,
python3-fyzz,
python3-imaging,
python3-rdflib,
python3-werkzeug,
# dev recommends
python3-pysqlite2,
Suggests:
python3-zmq,
python3-cwclientlib (>= 0.4.0),
w3c-dtd-xhtml,
xvfb,
Description: CubicWeb framework (Python 3)
CubicWeb is a semantic web application framework.
.
This package will install all the components you need to run cubicweb on a
single machine. You can also deploy cubicweb by running the different process
on different computers, in which case you need to install the corresponding
packages on the different hosts.
Package: python-cubicweb-postgresql-support
Architecture: all
Section: python
# postgresql-client packages for backup/restore of non local database
Replaces: cubicweb-postgresql-support (<< 3.24.0-1~)
Breaks: cubicweb-postgresql-support (<< 3.24.0-1~)
Provides: cubicweb-postgresql-support
Depends:
${misc:Depends},
python-cubicweb (= ${source:Version}),
python-psycopg2,
postgresql-client
Description: postgres support for the CubicWeb framework (Python 2)
CubicWeb is a semantic web application framework.
.
This is a dependency package to add support for using PostgreSQL for the
cubicweb repository.
Package: python3-cubicweb-postgresql-support
Architecture: all
Section: python
# postgresql-client packages for backup/restore of non local database
Depends:
${misc:Depends},
python3-cubicweb (= ${source:Version}),
python3-psycopg2,
postgresql-client
Description: postgres support for the CubicWeb framework (Python 3)
CubicWeb is a semantic web application framework.
.
This is a dependency package to add support for using PostgreSQL for the
cubicweb repository.
Package: python-cubicweb-twisted
Architecture: all
Section: python
Depends:
${misc:Depends},
python-cubicweb (= ${source:Version}),
python-twisted-web (<< 16.0.0),
Description: meta package to use Twisted as HTTP server for CubicWeb
CubicWeb is a semantic web application framework.
.
This package includes dependencies to run a Twisted based HTTP server to serve
the adaptative web interface.
Package: python-cubicweb-pyramid
Architecture: all
Section: python
Depends:
${misc:Depends},
python-cubicweb (= ${source:Version}),
python-pyramid (>= 1.5.0),
python-pyramid-multiauth,
python-waitress (>= 0.8.9),
python-wsgicors,
python-repoze.lru,
Recommends:
python-pyramid-debugtoolbar
Conflicts:
pyramid-cubicweb
Replaces:
pyramid-cubicweb
Description: meta package to use Pyramid as HTTP server for CubicWeb
Provides pyramid extensions to load a CubicWeb instance and serve it through
the pyramid stack.
Package: python3-cubicweb-pyramid
Architecture: all
Section: python
Depends:
${misc:Depends},
python3-cubicweb (= ${source:Version}),
python3-pyramid (>= 1.5.0),
python3-pyramid-multiauth,
python3-waitress (>= 0.8.9),
python3-wsgicors,
python3-repoze.lru,
Recommends:
python3-pyramid-debugtoolbar
Description: meta package to use Pyramid as HTTP server for CubicWeb (Python 3)
Provides pyramid extensions to load a CubicWeb instance and serve it through
the pyramid stack.
Package: cubicweb-ctl
Architecture: all
Depends:
${misc:Depends},
python-cubicweb (= ${source:Version})
Conflicts:
cubicweb-ctl3,
Description: tool to manage the CubicWeb framework
CubicWeb is a semantic web application framework.
.
This package provides a control script to manage (e.g. create, upgrade)
CubicWeb applications.
Package: cubicweb-ctl3
Architecture: all
Depends:
${misc:Depends},
python3-cubicweb (= ${source:Version})
Conflicts:
cubicweb-ctl,
Description: tool to manage the CubicWeb framework
CubicWeb is a semantic web application framework.
.
This package provides a control script to manage (e.g. create, upgrade)
CubicWeb applications.
Package: python-cubicweb-documentation
Architecture: all
Section: doc
Replaces: cubicweb-documentation (<< 3.24.0-1~)
Breaks: cubicweb-documentation (<< 3.24.0-1~)
Provides: cubicweb-documentation
Depends:
${misc:Depends},
${sphinxdoc:Depends},
Built-Using: ${sphinxdoc:Built-Using}
Recommends:
doc-base
Description: documentation for the CubicWeb framework
CubicWeb is a semantic web application framework.
.
This package provides the system's documentation.
# Transitional packages after renaming of (most) binary packages
Package: cubicweb
Architecture: all
Priority: optional
Section: oldlibs
Depends:
python-cubicweb, ${misc:Depends}
Description: transitional package
This is a transitional package. It can safely be removed.
Package: cubicweb-server
Architecture: all
Priority: optional
Section: oldlibs
Depends:
python-cubicweb, ${misc:Depends}
Description: transitional package
This is a transitional package. It can safely be removed.
Package: cubicweb-postgresql-support
Architecture: all
Priority: optional
Section: oldlibs
Depends:
python-cubicweb-postgresql-support, ${misc:Depends}
Description: transitional package
This is a transitional package. It can safely be removed.
Package: cubicweb-twisted
Architecture: all
Priority: extra
Section: oldlibs
Depends:
python-cubicweb-twisted, ${misc:Depends}
Description: transitional package
This is a transitional package. It can safely be removed.
Package: cubicweb-web
Architecture: all
Priority: optional
Section: oldlibs
Depends:
python-cubicweb, ${misc:Depends}
Description: transitional package
This is a transitional package. It can safely be removed.
Package: cubicweb-common
Architecture: all
Priority: optional
Section: oldlibs
Depends:
python-cubicweb, ${misc:Depends}
Description: transitional package
This is a transitional package. It can safely be removed.
Package: cubicweb-dev
Architecture: all
Priority: optional
Section: oldlibs
Depends:
python-cubicweb, ${misc:Depends}
Description: transitional package
This is a transitional package. It can safely be removed.
Package: cubicweb-documentation
Architecture: all
Priority: optional
Section: oldlibs
Depends:
python-cubicweb-documentation, ${misc:Depends}
Description: transitional package
This is a transitional package. It can safely be removed.