cubicweb/skeleton/debian/tests/pytest
author Nicolas Chauvat <nicolas.chauvat@logilab.fr>
Wed, 13 Mar 2019 10:26:15 +0100
changeset 12885 194e9ae964ed
parent 12709 280c9db41038
permissions -rw-r--r--
[server.rqlannotation] rename SQLGenAnnotator to RQLAnnotator This class is in charge of annotating the RQL syntax tree with various bits of information, like (in)variance, use of full-text-index, etc. It is a needed step before the generation of SQL, but does not touch SQL directly. Hence RQLAnnotator seems a better name.

#!/bin/sh

set -e
set -x

### Setup tests

# Uncomment if tests require database access
#service postgresql restart || service postgresql start
#trap 'service postgresql stop' EXIT

cp -r test tox.ini "$AUTOPKGTEST_TMP"
chown -R nobody:nogroup "$AUTOPKGTEST_TMP"

### Run tests

for py in $(py3versions -r 2>/dev/null); do
	cd "$AUTOPKGTEST_TMP"
	echo "Testing with $py:"
	su nobody --shell /bin/sh \
		-c "$py -m pytest -v"
done