cubicweb.spec
author Aurelien Campeas <aurelien.campeas@logilab.fr>
Fri, 13 Jun 2014 12:56:45 +0200
changeset 9792 1349398d744e
parent 9761 852880ba8b60
child 9865 fd45020eabfe
permissions -rw-r--r--
[test/migration] fix crash on execution This assertion is there for unclear reasons. ===================== unittest_migration.py ======================= -> creating tables [====================] -> inserting default user and default groups. -> storing the schema in the database [====================] -> database for instance data initialized. F ====================================================================== FAIL: test_db_creation (unittest_migration.BaseCreationTC) make sure database can be created ---------------------------------------------------------------------- Traceback (most recent call last) File "/home/auc/confs/forges/logilab/common/testlib.py", line 661, in _proceed testfunc(*args, **kwargs) File "/home/auc/confs/forges/cubicweb/test/unittest_migration.py", line 106, in test_db_creation handler.build_db_cache() File "/home/auc/confs/forges/cubicweb/devtools/__init__.py", line 469, in build_db_cache self.init_test_database() File "/home/auc/confs/forges/cubicweb/devtools/__init__.py", line 729, in init_test_database init_repository(self.config, interactive=False) File "/home/auc/confs/forges/cubicweb/server/__init__.py", line 217, in init_repository repo = Repository(config, vreg=vreg) File "/home/auc/confs/forges/cubicweb/server/repository.py", line 197, in __init__ self.init_cnxset_pool() File "/home/auc/confs/forges/cubicweb/server/repository.py", line 220, in init_cnxset_pool config.bootstrap_cubes() File "/home/auc/confs/forges/cubicweb/devtools/__init__.py", line 176, in bootstrap_cubes super(TestServerConfiguration, self).bootstrap_cubes() File "/home/auc/confs/forges/cubicweb/server/serverconfig.py", line 279, in bootstrap_cubes self.init_cubes(self.expand_cubes(splitstrip(line))) File "/home/auc/confs/forges/cubicweb/cwconfig.py", line 1022, in init_cubes super(CubicWebConfiguration, self).init_cubes(cubes) File "/home/auc/confs/forges/cubicweb/cwconfig.py", line 798, in init_cubes assert self._cubes is None, repr(self._cubes) AssertionError: ('card', 'file', 'localperms', 'tag')

%if 0%{?el5}
%define python python26
%define __python /usr/bin/python2.6
%else
%define python python
%define __python /usr/bin/python
%endif

Name:           cubicweb
Version:        3.19.1
Release:        logilab.1%{?dist}
Summary:        CubicWeb is a semantic web application framework
Source0:        http://download.logilab.org/pub/cubicweb/cubicweb-%{version}.tar.gz
License:        LGPLv2+
Group:          Development/Languages/Python
Vendor:         Logilab <contact@logilab.fr>
Url:            http://www.cubicweb.org/project/cubicweb

BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-buildroot
BuildArch:      noarch

Requires:       %{python}
Requires:       %{python}-logilab-common >= 0.60.0
Requires:       %{python}-logilab-mtconverter >= 0.8.0
Requires:       %{python}-rql >= 0.31.2
Requires:       %{python}-yams >= 0.39.1
Requires:       %{python}-logilab-database >= 1.12.1
Requires:       %{python}-passlib
Requires:       %{python}-lxml
Requires:       %{python}-twisted-web
# the schema view uses `dot'; at least on el5, png output requires graphviz-gd
Requires:       graphviz-gd
Requires:       gettext

BuildRequires:  %{python}

%description
a repository of entities / relations for knowledge management

%prep
%setup -q
%if 0%{?el5}
# change the python version in shebangs
find . -name '*.py' -type f -print0 |  xargs -0 sed -i '1,3s;^#!.*python.*$;#! /usr/bin/python2.6;'
%endif

%install
NO_SETUPTOOLS=1 %{__python} setup.py --quiet install --no-compile --prefix=%{_prefix} --root="$RPM_BUILD_ROOT"
mkdir -p $RPM_BUILD_ROOT/var/log/cubicweb

%clean
rm -rf $RPM_BUILD_ROOT

%files 
%defattr(-, root, root)
%dir /var/log/cubicweb
/*