[server/migractions] finish migration to repoapi objects
Changeset 241b1232ed7f (Use repoapi instead of dbapi for cwctl shell,
upgrade and db-init) only did half of the job. It left the migration
handler with both a session (cubicweb.server.session.Session) and a cnx
(cubicweb.repoapi.ClientConnection) attribute with different ideas of
what Connection they were talking to.
With this change, we:
- make the caller responsible of disabling security on the Connection if
it wants to
- turn mih.session into an actual attribute, set on __init__
- same for cnx (the client connection)
- drop the "lazy connection" logic, and establish the connection
up-front
- always go through the connection instead of the session when we need
to talk to the db
#! /bin/sh -e
case "$1" in
configure|abort-upgrade|abort-remove|abort-deconfigure)
update-rc.d cubicweb defaults 99 >/dev/null
;;
*)
echo "postinst called with unknown argument \`$1'" >&2
exit 1
;;
esac
if [ "$1" = configure ]; then
# XXX bw compat: erudi -> cubicweb migration
if [ -e "/etc/erudi.d/" ]; then
mv /etc/erudi.d/* /etc/cubicweb.d/ && (
echo 'moved /etc/erudi.d/* to /etc/cubicweb.d/'
sed -i s/ginco/cubicweb/g /etc/*/*.py
sed -i s/erudi/cubicweb/ */*.conf
) || true # empty dir
fi
if [ -e "/var/log/erudi/" ]; then
mv /var/log/erudi/* /var/log/cubicweb/ && (
echo 'moved /var/log/erudi/* to /var/log/cubicweb/'
) || true # empty dir
fi
if [ -e "/var/lib/erudi/backup" ]; then
mv /var/lib/erudi/backup/* /var/lib/cubicweb/backup/ && (
echo 'moved /var/lib/erudi/backup/* to /var/lib/cubicweb/backup/'
) || true # empty dir
fi
if [ -e "/var/lib/erudi/instances" ]; then
mv /var/lib/erudi/instances/* /var/lib/cubicweb/instances/ && (
echo 'moved /var/lib/erudi/instances/* to /var/lib/cubicweb/instances/'
) || true # empty dir
fi
fi
#DEBHELPER#
exit 0