[server] prevent returning closed cursor to the database pool
In since c8c6ad8 init_repository use repo.internal_cnx() instead of
repo.system_source.get_connection() so it use the pool and we should not close
cursors from the pool before returning it back. Otherwise we may have
"connection already closed" error.
This bug only trigger when connection-pool-size = 1. Since we are moving to use
a dynamic pooler we need to get this fixed.
This does not occur with sqlite since the connection wrapper instantiate new
cursor everytime, but this occur with other databases.
Tests: unittest
Depends:
python3-cubicweb, cubicweb-ctl,
@builddeps@,
python3-pytest,
python3-flake8,
python3-psycopg2, postgresql, postgresql-plpython,
python3-ldap3, slapd, ldap-utils
Restrictions: allow-stderr, isolation-container
Tests: skeleton-packaging
Depends:
python3-cubicweb, cubicweb-ctl,
python3-pyramid, python3-wsgicors,
devscripts, equivs, lintian, autopkgtest
Restrictions: allow-stderr, needs-root