[testlib] call init_config once the config has been properly bootstraped
This should be done right after repository instantiation and as such involves
giving CWTC.init_config as a callback to the test database handler (which will
itself gives it to the repository initialization function).
This unfortunatly requires to pass the init_config method to the
server.init_repository function because it has to be called after the config has
been initialized (which is done in Repository.__init__) but before the migration
handler is instantiated (which will call 'server_maintainance' hook, hence may
require the proper config). Another way to fix this would be to change the
initialization sequence, but this is another story.
Closes #3749378
#! /bin/sh -ecase "$1" in configure|abort-upgrade|abort-remove|abort-deconfigure) update-rc.d cubicweb defaults 99 >/dev/null ;; *) echo "postinst called with unknown argument \`$1'" >&2 exit 1 ;;esacif [ "$1" = configure ]; then # XXX bw compat: erudi -> cubicweb migration if [ -e "/etc/erudi.d/" ]; then mv /etc/erudi.d/* /etc/cubicweb.d/ && ( echo 'moved /etc/erudi.d/* to /etc/cubicweb.d/' sed -i s/ginco/cubicweb/g /etc/*/*.py sed -i s/erudi/cubicweb/ */*.conf ) || true # empty dir fi if [ -e "/var/log/erudi/" ]; then mv /var/log/erudi/* /var/log/cubicweb/ && ( echo 'moved /var/log/erudi/* to /var/log/cubicweb/' ) || true # empty dir fi if [ -e "/var/lib/erudi/backup" ]; then mv /var/lib/erudi/backup/* /var/lib/cubicweb/backup/ && ( echo 'moved /var/lib/erudi/backup/* to /var/lib/cubicweb/backup/' ) || true # empty dir fi if [ -e "/var/lib/erudi/instances" ]; then mv /var/lib/erudi/instances/* /var/lib/cubicweb/instances/ && ( echo 'moved /var/lib/erudi/instances/* to /var/lib/cubicweb/instances/' ) || true # empty dir fifi#DEBHELPER#exit 0