skeleton/setup.py
changeset 5360 96893296772f
parent 5334 7da1a6ca8f65
child 5382 cb5dfea92285
--- a/skeleton/setup.py	Tue Apr 20 18:10:42 2010 +0200
+++ b/skeleton/setup.py	Tue Apr 20 18:25:56 2010 +0200
@@ -139,19 +139,12 @@
 
 def install(**kwargs):
     """setup entry point"""
-    try:
-        if USE_SETUPTOOLS:
+    if USE_SETUPTOOLS:
+        if '--force-manifest' in sys.argv:
             sys.argv.remove('--force-manifest')
-    except:
-        pass
-    try:
-        if not USE_SETUPTOOLS:
-            # install-layout option was introduced in 2.5.3-1~exp1
-            if sys.versioninfo < (2, 5, 4):
-                sys.argv.remove('--install-layout=deb')
-                print "W: remove '--install-layout=deb' option"
-    except:
-        pass
+    # install-layout option was introduced in 2.5.3-1~exp1
+    elif sys.version_info < (2, 5, 4) and '--install-layout=deb' in sys.argv:
+        sys.argv.remove('--install-layout=deb')
     kwargs['package_dir'] = {modname : '.'}
     packages = [modname] + get_packages(os.getcwd(), modname)
     if USE_SETUPTOOLS and install_requires: