sampleapp/setup.py
changeset 11483 7b7ed56bf2fb
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/sampleapp/setup.py	Sun Jul 06 18:25:31 2014 +0200
@@ -0,0 +1,39 @@
+import os
+
+from setuptools import setup, find_packages
+
+here = os.path.abspath(os.path.dirname(__file__))
+README = open(os.path.join(here, 'README.txt')).read()
+CHANGES = open(os.path.join(here, 'CHANGES.txt')).read()
+
+requires = [
+    'pyramid',
+    'pyramid_debugtoolbar',
+    'waitress',
+    ]
+
+setup(name='sampleapp',
+      version='0.0',
+      description='sampleapp',
+      long_description=README + '\n\n' + CHANGES,
+      classifiers=[
+        "Programming Language :: Python",
+        "Framework :: Pyramid",
+        "Topic :: Internet :: WWW/HTTP",
+        "Topic :: Internet :: WWW/HTTP :: WSGI :: Application",
+        ],
+      author='',
+      author_email='',
+      url='',
+      keywords='web pyramid pylons',
+      packages=find_packages(),
+      include_package_data=True,
+      zip_safe=False,
+      install_requires=requires,
+      tests_require=requires,
+      test_suite="sampleapp",
+      entry_points="""\
+      [paste.app_factory]
+      main = sampleapp:main
+      """,
+      )