setup.py
changeset 11276 6eeb7abda47a
parent 11057 0b59724cb3f2
child 11282 386fff3fa2ff
--- a/setup.py	Tue Jun 07 10:05:30 2016 +0200
+++ b/setup.py	Fri Jun 10 13:23:54 2016 +0200
@@ -21,6 +21,7 @@
 """Generic Setup script, takes package info from __pkginfo__.py file
 """
 
+import io
 import os
 import sys
 import shutil
@@ -53,7 +54,8 @@
 author = __pkginfo__['author']
 author_email = __pkginfo__['author_email']
 
-long_description = open('README').read()
+with io.open('README', encoding='utf-8') as f:
+    long_description = f.read()
 
 # import optional features
 if USE_SETUPTOOLS: