setup.py
changeset 12255 08628d6d57ee
parent 12254 2060ee44ea9a
child 12256 af1245fe6b7b
--- a/setup.py	Wed Jan 24 11:40:12 2018 +0100
+++ b/setup.py	Wed Jan 24 11:43:13 2018 +0100
@@ -27,7 +27,7 @@
 from os.path import dirname, exists, isdir, join
 
 from setuptools import setup
-from distutils.command import install_data
+
 
 here = dirname(__file__)
 
@@ -70,16 +70,6 @@
     return result
 
 
-# re-enable copying data files in sys.prefix
-# overwrite install_data to use sys.prefix instead of the egg directory
-class MyInstallData(install_data.install_data):
-    """A class that manages data files installation"""
-    def run(self):
-        _old_install_dir = self.install_dir
-        if self.install_dir.endswith('egg'):
-            self.install_dir = sys.prefix
-        install_data.install_data.run(self)
-        self.install_dir = _old_install_dir
 try:
     import setuptools.command.easy_install # only if easy_install available
     # monkey patch: Crack SandboxViolation verification
@@ -165,8 +155,5 @@
             'pyzmq',
         ],
     },
-    cmdclass={
-        'install_data': MyInstallData,
-    },
     zip_safe=False,
 )