debian/rules
branchstable
changeset 7767 07c74f5585d1
parent 7512 d2de5fb0cc33
child 8476 864a92b10cb8
--- a/debian/rules	Wed Sep 07 16:56:27 2011 +0200
+++ b/debian/rules	Wed Sep 07 11:37:41 2011 +0200
@@ -10,14 +10,11 @@
 build: build-stamp
 build-stamp:
 	dh_testdir
-	# XXX doesn't work if logilab-doctools, logilab-xml are not in build depends
-	# and I can't get pbuilder find them in its chroot :(
-	# cd doc && make
-	# FIXME cleanup and use sphinx-build as build-depends ?
 	NO_SETUPTOOLS=1 python setup.py build
-	# XXX uncomment this and associated build-depends in control
-	#when necessary sphinx version is in all built distribution
-	#PYTHONPATH=$(CURDIR)/.. $(MAKE) -C doc/book/en all
+	# documentation build is now made optional since it can break for old
+	# distributions and we don't want to block a new release of Cubicweb
+	# because of documentation issues.
+	-PYTHONPATH=$(CURDIR)/.. $(MAKE) -C doc/book/en all
 	touch build-stamp
 
 clean:
@@ -73,7 +70,7 @@
 	dh_installman -i
 	dh_installchangelogs -i
 	dh_link -i
-	dh_compress -i -X.py -X.ini -X.xml
+	dh_compress -i -X.py -X.ini -X.xml -X.js -X.rst
 	dh_fixperms -i
 	dh_installdeb -i
 	dh_gencontrol  -i