debian/rules
changeset 9205 ea32e964fbf8
parent 9193 eaa58d1c7d5f
child 9208 7ae95f48e2f0
equal deleted inserted replaced
9149:31ed9dd946d1 9205:ea32e964fbf8
    16 	ln -sf $(CURDIR) debian/pythonpath/cubicweb
    16 	ln -sf $(CURDIR) debian/pythonpath/cubicweb
    17 	# documentation build is now made optional since it can break for old
    17 	# documentation build is now made optional since it can break for old
    18 	# distributions and we don't want to block a new release of Cubicweb
    18 	# distributions and we don't want to block a new release of Cubicweb
    19 	# because of documentation issues.
    19 	# because of documentation issues.
    20 	-PYTHONPATH=$${PYTHONPATH:+$${PYTHONPATH}:}$(CURDIR)/debian/pythonpath $(MAKE) -C doc/book/en all
    20 	-PYTHONPATH=$${PYTHONPATH:+$${PYTHONPATH}:}$(CURDIR)/debian/pythonpath $(MAKE) -C doc/book/en all
    21 	# squeeze has a broken combination of jquery and sphinx, fix it up so search works(ish)
       
    22 	if grep -q jQuery\\.className doc/html/_static/doctools.js && grep -q "jQuery JavaScript Library v1\.4\." doc/html/_static/jquery.js; then \
       
    23 	    echo 'Patching doctools.js for jQuery 1.4 compat'; \
       
    24 	    sed -i 's/jQuery\.className.has(node\.parentNode, className)/jQuery(node.parentNode).hasClass(className)/' doc/html/_static/doctools.js; \
       
    25 	fi
       
    26 	rm -rf debian/pythonpath
    21 	rm -rf debian/pythonpath
    27 	touch build-stamp
    22 	touch build-stamp
    28 
    23 
    29 clean:
    24 clean:
    30 	dh_testdir
    25 	dh_testdir
    70 
    65 
    71 # Build architecture-independent files here.
    66 # Build architecture-independent files here.
    72 binary-indep: build install
    67 binary-indep: build install
    73 	dh_testdir
    68 	dh_testdir
    74 	dh_testroot -i
    69 	dh_testroot -i
    75 	dh_pycentral -i
    70 	dh_python2 -i
    76 	dh_installinit -i -n --name cubicweb -u"defaults 99"
    71 	dh_installinit -i -n --name cubicweb -u"defaults 99"
    77 	dh_installlogrotate -i
    72 	dh_installlogrotate -i
    78 	dh_installdocs -i -A README
    73 	dh_installdocs -i -A README
    79 	dh_installman -i
    74 	dh_installman -i
    80 	dh_installchangelogs -i
    75 	dh_installchangelogs -i