debian/rules
changeset 1821 d9d391bc8e1b
parent 1043 7c21ca28327f
child 1822 b0ee88e8e759
equal deleted inserted replaced
1820:43419596b59f 1821:d9d391bc8e1b
    37 	python setup.py -q install --no-compile --prefix=debian/tmp/usr
    37 	python setup.py -q install --no-compile --prefix=debian/tmp/usr
    38 
    38 
    39 	# Put all the python library and data in cubicweb-common
    39 	# Put all the python library and data in cubicweb-common
    40 	# and scripts in cubicweb-server
    40 	# and scripts in cubicweb-server
    41 	dh_install -vi
    41 	dh_install -vi
       
    42 	# cwctl in the cubicweb-ctl package
       
    43 	rm -f debian/cubicweb-common/usr/lib/${PY_VERSION}/site-packages/cubicweb/cwctl.py
       
    44 
    42 	dh_lintian
    45 	dh_lintian
    43 
    46 
    44 	# Remove unittests directory (should be available in cubicweb-dev only)
    47 	# Remove unittests directory (should be available in cubicweb-dev only)
    45 	rm -rf debian/cubicweb-server/usr/lib/${PY_VERSION}/site-packages/cubicweb/server/test
    48 	rm -rf debian/cubicweb-server/usr/lib/${PY_VERSION}/site-packages/cubicweb/server/test
    46 	rm -rf debian/cubicweb-server/usr/lib/${PY_VERSION}/site-packages/cubicweb/sobjects/test
    49 	rm -rf debian/cubicweb-server/usr/lib/${PY_VERSION}/site-packages/cubicweb/sobjects/test