debian/rules
changeset 5354 ba9fe740688c
parent 4542 d2559cc88341
child 6506 c1661ea815dc
equal deleted inserted replaced
5353:cb8ac7263f8a 5354:ba9fe740688c
    12 	dh_testdir
    12 	dh_testdir
    13 	# XXX doesn't work if logilab-doctools, logilab-xml are not in build depends
    13 	# XXX doesn't work if logilab-doctools, logilab-xml are not in build depends
    14 	# and I can't get pbuilder find them in its chroot :(
    14 	# and I can't get pbuilder find them in its chroot :(
    15 	# cd doc && make
    15 	# cd doc && make
    16 	# FIXME cleanup and use sphinx-build as build-depends ?
    16 	# FIXME cleanup and use sphinx-build as build-depends ?
    17 	python setup.py build
    17 	NO_SETUPTOOLS=1 python setup.py build
    18 	touch build-stamp
    18 	touch build-stamp
    19 
    19 
    20 clean:
    20 clean:
    21 	dh_testdir
    21 	dh_testdir
    22 	dh_testroot
    22 	dh_testroot
    32 	dh_testroot
    32 	dh_testroot
    33 	dh_clean
    33 	dh_clean
    34 	dh_installdirs
    34 	dh_installdirs
    35 
    35 
    36 	#python setup.py install_lib --no-compile --install-dir=debian/cubicweb-common/usr/lib/python2.4/site-packages/
    36 	#python setup.py install_lib --no-compile --install-dir=debian/cubicweb-common/usr/lib/python2.4/site-packages/
    37 	python setup.py -q install --no-compile --prefix=debian/tmp/usr
    37 	NO_SETUPTOOLS=1 python setup.py -q install --no-compile --prefix=debian/tmp/usr
    38 
    38 
    39 	# Put all the python library and data in cubicweb-common
    39 	# Put all the python library and data in cubicweb-common
    40 	# and scripts in cubicweb-server
    40 	# and scripts in cubicweb-server
    41 	dh_install -vi
    41 	dh_install -vi
    42 	# cwctl in the cubicweb-ctl package
    42 	# cwctl in the cubicweb-ctl package