debian/cubicweb-common.postinst
changeset 241 89e11cc865b2
parent 240 6ba006fb95d1
child 242 26bd3a406889
equal deleted inserted replaced
240:6ba006fb95d1 241:89e11cc865b2
     1 #! /bin/sh -e
       
     2 
       
     3 if [ "$1" = configure ]; then
       
     4     # XXX bw compat: erudi -> cubicweb migration
       
     5     if [ -e "/usr/share/erudi/templates/" ]; then
       
     6       # skip the "shared" subdirectory by moving it first, restoring it later
       
     7       mv /usr/share/erudi/templates/shared /usr/share/erudi/
       
     8       mv /usr/share/erudi/templates/* /usr/share/cubicweb/cubes/
       
     9       mv /usr/share/erudi/shared /usr/share/erudi/templates
       
    10       echo 'moved /usr/share/erudi/templates/* to /usr/share/cubicweb/cubes/'
       
    11     fi
       
    12 fi 
       
    13 #DEBHELPER#
       
    14  
       
    15 exit 0