equal
deleted
inserted
replaced
15 mkdir -p debian/pythonpath |
15 mkdir -p debian/pythonpath |
16 ln -sf $(CURDIR) debian/pythonpath/cubicweb |
16 ln -sf $(CURDIR) debian/pythonpath/cubicweb |
17 # documentation build is now made optional since it can break for old |
17 # documentation build is now made optional since it can break for old |
18 # distributions and we don't want to block a new release of Cubicweb |
18 # distributions and we don't want to block a new release of Cubicweb |
19 # because of documentation issues. |
19 # because of documentation issues. |
20 -PYTHONPATH=$${PYTHONPATH:+$${PYTHONPATH}:}$(CURDIR)/debian/pythonpath $(MAKE) -C doc/book/en all |
20 -PYTHONPATH=$${PYTHONPATH:+$${PYTHONPATH}:}$(CURDIR)/debian/pythonpath $(MAKE) -C doc all |
21 rm -rf debian/pythonpath |
21 rm -rf debian/pythonpath |
22 touch build-stamp |
22 touch build-stamp |
23 |
23 |
24 clean: |
24 clean: |
25 dh_testdir |
25 dh_testdir |
26 rm -f build-stamp configure-stamp |
26 rm -f build-stamp configure-stamp |
27 rm -rf build |
27 rm -rf build |
28 #rm -rf debian/cubicweb-*/ |
28 #rm -rf debian/cubicweb-*/ |
29 find . -name "*.pyc" -delete |
29 find . -name "*.pyc" -delete |
|
30 -$(MAKE) -C doc clean |
30 rm -f $(basename $(wildcard debian/*.in)) |
31 rm -f $(basename $(wildcard debian/*.in)) |
31 dh_clean |
32 dh_clean |
32 |
33 |
33 install: build $(basename $(wildcard debian/*.in)) |
34 install: build $(basename $(wildcard debian/*.in)) |
34 dh_testdir |
35 dh_testdir |
68 dh_python2 -i |
69 dh_python2 -i |
69 dh_installinit -i -n --name cubicweb -u"defaults 99" |
70 dh_installinit -i -n --name cubicweb -u"defaults 99" |
70 dh_installlogrotate -i |
71 dh_installlogrotate -i |
71 dh_installdocs -i -A README |
72 dh_installdocs -i -A README |
72 dh_installman -i |
73 dh_installman -i |
73 dh_installchangelogs -i |
74 dh_installchangelogs -i -Xdoc/changes |
74 dh_link -i |
75 dh_link -i |
75 dh_compress -i -X.py -X.ini -X.xml -X.js -X.rst -X.txt |
76 dh_compress -i -X.py -X.ini -X.xml -X.js -X.rst -X.txt |
76 dh_fixperms -i |
77 dh_fixperms -i |
77 dh_installdeb -i |
78 dh_installdeb -i |
78 dh_gencontrol -i |
79 dh_gencontrol -i |