equal
deleted
inserted
replaced
9 |
9 |
10 build: build-stamp |
10 build: build-stamp |
11 build-stamp: |
11 build-stamp: |
12 dh_testdir |
12 dh_testdir |
13 NO_SETUPTOOLS=1 python setup.py build |
13 NO_SETUPTOOLS=1 python setup.py build |
|
14 # cubicweb.foo needs to be importable by sphinx, so create a cubicweb symlink to the source dir |
|
15 mkdir -p debian/pythonpath |
|
16 ln -sf $(CURDIR) debian/pythonpath/cubicweb |
14 # documentation build is now made optional since it can break for old |
17 # documentation build is now made optional since it can break for old |
15 # distributions and we don't want to block a new release of Cubicweb |
18 # distributions and we don't want to block a new release of Cubicweb |
16 # because of documentation issues. |
19 # because of documentation issues. |
17 -PYTHONPATH=$(CURDIR)/.. $(MAKE) -C doc/book/en all |
20 -PYTHONPATH=$${PYTHONPATH:+$${PYTHONPATH}:}$(CURDIR)/debian/pythonpath $(MAKE) -C doc/book/en all |
|
21 rm -rf debian/pythonpath |
18 touch build-stamp |
22 touch build-stamp |
19 |
23 |
20 clean: |
24 clean: |
21 dh_testdir |
25 dh_testdir |
22 dh_testroot |
26 dh_testroot |